Back to overview
Degraded

Problems accessing staff emails

Jan 14 at 09:13pm EET
Affected services
oakwayrblx.xyz

Resolved
Jan 14 at 09:19pm EET

Emails should be operational and accessible.

Created
Jan 14 at 09:13pm EET

Staff cant currently access Google apps. This is being investigated.